CONTENT Objekt und Image-renderObj in Typo3 7.6.9

1 Beitrag in diesem Thema

Hallo zusammen,

ich bin echt am verzweifeln. Irgendwie bekomme ich das Image nicht gerendert.
Der Text kommt, nur das Image nicht! Warum? Was mache ich falsch?
Bitte um Hilfe.

lib.startHeaderSliderImages = CONTENT
lib.startHeaderSliderImages {
    wrap = |
    table = tt_content
    select.languageField = sys_language_uid
    select.selectFields = bodytext,image
    select.where = colPos = 1
    select.pidInList = 54

    renderObj = COA
    renderObj{
        wrap = <div class="slider-item">|</div>
      
        10 = FILES
        10 {
            required = 1
            references {
                table = tt_content
                fieldName = image
            }
            renderObj = IMAGE
            renderObj {
                file.import.data = file:current:originalUid // file:current:uid
                file.width = 1920c
                file.height = 600c
                # stdWrap.typolink.parameter.data = file:current:link
                altText.data = file:current:description // file:current:title // file:current:alternative
            }
            wrap = <div class="slider-item-image">|</div>
        }
        
        20 = COA
        20 {
            10 = TEXT
            10 {
                required=1
                wrap = <div class="slider-item-text">|</div>
                field = bodytext
            }
        }
    }
}

Ich hoffe einem von Euch fällt ein Fehler auf.
Vielen Dank im Voraus!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an um zu kommentieren

Du musst ein Benutzerkonto haben um einen Kommentar hinterlassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Geht einfach!


Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.


Jetzt anmelden