Björn

Mitglieder
  • Gesamte Inhalte

    1
  • Registriert

  • Letzter Besuch

Ansehen in der Community

0 Neutral

Über Björn

  • Rang
    Mitglied

Kontakt

  • ICQ 0
  1. Problem Verweis

    Hallo Leute, ich habe ein Problem. Wie in der angehängten Grafik angezeigt werden bei mir von der gleichen Seite falsche Verweise in der Fremdsprache erzeugt. (Oben deutscher Quellcode, unten Englischer) Ich bin ratlos und weiß nicht wieso die Links falsch erzeugt werden. Dadurch funktioniert meine komplette Navigation in den Fremdsprachen nicht mehr. Auf deutsch funktioniert alles wunderbar. Hier mein TS zu den Fremdsprachen: config { // Administrator settings admPanel = {$config.adminPanel} debug = {$config.debug} doctype = xhtml_trans // Character sets renderCharset = utf-8 metaCharset = utf-8 // Cache settings cache_period = 43200 sendCacheHeaders = 1 baseURL = http://www.fzth.de/ simulateStaticDocuments = 0 tx_realurl_enable = 0 // Language Settings uniqueLinkVars = 1 linkVars = L(1-6) sys_language_uid = 0 sys_language_overlay = 1 sys_language_mode = content_fallback language = de locale_all = de_DE.UTF-8 htmlTag_langKey = de // Link settings # # absRefPrefix = / prefixLocalAnchors = all // Remove targets from links intTarget = extTarget = // Indexed Search index_enable = 1 index_externals = 1 // Code cleaning disablePrefixComment = 1 // Move default CSS and JS to external file removeDefaultJS = external inlineStyle2TempFile = 1 // Protect mail addresses from spamming spamProtectEmailAddresses = -3 spamProtectEmailAddresses_atSubst = @<span style="display:none;">remove-this.</span> // Comment in the <head> tag headerComment ( ) } page.config ( language = de locale_all = de_DE.UTF-8 ) # Set baseURL setting for http or https config.baseURL = http://{$config.domain}/ [globalString = IENV:TYPO3_SITE_URL=https://{$config.domain}/]'>https://{$config.domain}/] config.baseURL = https://{$config.domain}/ [global] // Condition to switch the doctype and xml prologue [browser = msie] && [version = <7] config { doctypeSwitch = 1 } [global] // Condition to set language according to L POST/GET variable [globalVar = GP:L = 1] config { sys_language_uid = 1 language = en locale_all = en_GB.UTF-8 htmlTag_langKey = en } [global] [globalVar = GP:L = 2] config { sys_language_uid = 2 language = dk locale_all = dk_DK.UTF-8 htmlTag_langKey = en } [global] [globalVar = GP:L = 3] config { sys_language_uid = 3 language = fr locale_all = fr_FR.UTF-8 htmlTag_langKey = fr } [global] [globalVar = GP:L = 4] config { htmlTag_langKey = nl sys_language_uid = 4 language = nl locale_all = nl_NL.UTF-8 } [global] [globalVar = GP:L = 5] config { sys_language_uid = 5 language = it locale_all = it_IT.UTF-8 htmlTag_langKey = it } [global] und hier meine .htaccess: AddHandler php5wrap .php <IfModule mod_rewrite.c> RewriteEngine On RewriteBase / RewriteCond %{HTTP_HOST} !^www\.fzth\.de$ RewriteRule ^(.*)$ http://www.fzth.de/$1 [L,R=301] Redirect /mail http://server2.imitsch.eu/squirrelmail/ # Prevent serving TYPO3 404 pages for missing files RewriteRule ^(typo3(conf|temp)?|fileadmin|uploads|t3lib|clear.gif|index.php|favicon.ico) - [L] # Do not rewrite static resources RewriteCond %{REQUEST_FILENAME} -f [OR] RewriteCond %{REQUEST_FILENAME} -d [OR] RewriteCond %{REQUEST_FILENAME} -l RewriteRule .* - [L] # Rewrite the rest to index.php RewriteRule .* /index.php [L] </IfModule> Vielen Dank schonmal im Vorraus. Vielleicht kann mir ja einer helfen / anregungen geben woran das liegen kann. MfG Björn